Netatmo Plugin aktualisiert keine Wetterdaten

Hallo zusammen,

ich verwende das HC2 mit aktuellem Firmwarestand. Ich möchte gern meine netatmo Wetterstation (Innen und Außenmodul) über das vorhandene PlugIn installieren. Den Zugriff zu den Wetterdaten bekomme ich, nur leider werden die Wetterdaten nicht aktualisiert. Die einzige Aktualisierung kann ich über einen Restart des HC2 erreichen. Ich habe schon eine 2. App bei netatmo angelegt, mit dem Abfragetimer experimentiert (verschieden Werte zwischen 60 und 1260) alles ohne Erfolg. Auch schon mehrfach das PlugIn gelöscht und neu installiert, alles vergebens. Die angezeigten Werte bleiben bis zum Restart des HC2 auch über Tage konstant egal was das Wetter macht.

Nun meine Anliegen: Hat jemand einen LUA Script, wo ich aktiv die Werte in einem bestimmten Zeitraster bei netatmo mir abholen kann, da das PlugIn offensichtlich die Werte nicht regelmäßig holt bzw. nur nach einem HC2 Neustart.

Danke vorab für eure Hilfe

1 Like

Ich habe das gleiche Problem seit ca. Juni 19 und leider noch keine Lösung gefunden.
Bist du eventuell weiter gekommen?

Gruß
Tucher

Hallo tucher,
leider nicht. Sobald ich das HC2 neu starte bekomme ich vom Plugin die aktuellen Daten, aber sonst werden diese nicht aktualisiert. Aber ich kann ja nur den Abfragetimer variieren, sonst gibt es ja nichts im Plugin. Da beim Neustart die Daten geholt werden, fehlt m.E. ein Trigger im Plugin. Wenn jemand in der Gemeinschaft uns dabei helfen könnte, wäre viel gewonnen.

Welches Script verwendet Ihr? Oder geht’s nur um das Plug-in?

Aktualisierung klappt bei mir auch nicht.

bei mir geht es rein um das Plug-In.
Die einzelnen Module werden mir angezeigt, aber die Daten der Module werden nicht Synchronisiert.
Ausnahme ist bei einem Neustart des HC2. Da bekomme ich einmalig aktuelle Werte von jedem Modul.

Bei mir geht es auch nur um das Plugin (kein Script), genau so wie es auch tucher schreibt.

Ich habe gerade im Fibaro-Forum eventuell eine Antwort gefunden.

Hast du evtl. ein Modul, dessen Batterien leer sind oder rausgenommen sind?
Ich hab tatsächlich den Regensensor und Windsensor derzeit nicht in Betrieb, aber mit meinem Konto noch verknüpft.

Im Fibaro-Forum steht auch das jemand keine aktuellen Daten bekommen hat, nachdem derjenige sein Regensensor “eingewintert” hat. Nachdem er die Batterien wieder in den Sensor hat, habe er wieder aktuelle Werte geliefert bekommen.

Found the answer.
I have a rain module, and when i removed batteries for the winter. The HC2 could not pull anything anymore.
Without much investigation, i think the plugin got stuck when trying to read the last entries in API. Rain module was the last module i included.
So when the HC2 started, it read all the values before getting stuck at the last for the rain module. Just my guess.
Put batteries back in, started HC2, everything OK

Ich werde das evtl. heute noch testen wenn ich zuhause bin.

Also ich hab´s getestet und das war des Rätsels Lösung.
Ich habe wieder Batterien in den Regensensor und Windsensor.
Funktioniert wieder alles wie gewohnt.

Manchmal könnte es so einfach sein.

Gruß
Tucher

Gut zu wissen, danke.
Ich stelle jetzt das Außenmodul auf Kabel um. Der ewige Batterie Wechsel geht mir auf die Nerven.

Hallo tucher,

Danke für den Hinweis.
Nein ich habe nur das Innenmodul und das Außenmodul, beide funktionieren und das Außenmodul hat volle Batterien.
Aber der Weihnachtsmann hat mir überraschenderweise ein Windmodul unter dem Baum gelegt. Jetzt muss ich doch auf das virtuelle Modul von [Sankotronic] wechseln: (https://forum.fibaro.com/files/file/93-netatmo-weather-station-vd-scene-standalone/),
weil das PlugIn den Windmesser nicht auswerten kann.
Trotzdem großen Dank für Deine Mithilfe