Batterie Spam

Hallo,
ich habe mal von dieser Seite ein Batterie Status Skript bei mir in der HC2 installiert. Bin mir nicht sicher ob mein Problem daher rührt: Wenn eine Batterie zur Neige geht, dann bekomme ich alle 30Minuten eine Mitteilung in meinen E-Mail Postkasten. Das sorgt dann dafür, dass ich über Nacht mal eben über 40 E-Mails im Kasten habe. Wo kann ich das Umstellen, dass die Mails nicht mehr versendet werden? Ich habe das Skript komplett gelöscht und keine Mitteilung bei “Meldungen” in den Steuerungen mehr aktiv!?

Grüße!

Das kann man in den Einstellungen des Moduls abstellen. Hat mit dem Skript nichts zu tun.

gefunden! Man wie nervig.
Wer programmiert sowas? Alle 30Minuten eine Meldung…
Und warum gibt es dafür keine globale Einstellung die sich die Module dann ziehen?

Danke!

Schon ne Weile her aber noch aktuell. Falls man eine Menge Batterie betriebener Geräte hat und man nicht in jedem einzeln die Option zum Benachrichtigen deaktivieren will kann man folgendes Script benutzen:

--[[
%% properties
%% events
%% globals
--]]

local devices = api.get('/devices')
for _, dev in ipairs(devices) do
  	if dev.properties.batteryLowNotification ~= nil and dev.parentId == 1 then
  		fibaro:debug("Id: " .. dev.id .. " | batteryLowNotification: " .. tostring(dev.properties.batteryLowNotification))
  		if dev.properties.batteryLowNotification == true then
     		fibaro:debug("-> Id: " .. dev.id .. " | " .. dev.name .. " | Ändere Eigenschaft: " .. " false")
     		dev.properties.batteryLowNotification = false
     		api.put('/devices/' .. dev.parentId, dev)
     		fibaro:sleep(100)
  		end
    end
end
fibaro:debug("ready")

debug:

..
[DEBUG] 10:11:31: Id: 340 | batteryLowNotification: false
[DEBUG] 10:11:31: Id: 354 | batteryLowNotification: false
[DEBUG] 10:11:31: Id: 358 | batteryLowNotification: true
[DEBUG] 10:11:31: -> Id: 358 | Wassersensor Küche | Ändere Eigenschaft: false
[DEBUG] 10:11:32: ready

Kann man auch bei neu hinzugefügten Modulen einmalig drüberlaufen lassen.

Gruß

1 Like